Trending questions in DevOps & Agile

0 votes
1 answer

How to run Ansible without hosts file?

Hey @Ruth, you can use ansible without using ...READ MORE

Feb 1, 2019 in Ansible by Anisha
• 3,967 views
0 votes
1 answer

How to monitor an application using Nagios core?

Here is what you can try. Since ...READ MORE

Dec 28, 2018 in DevOps & Agile by Damon Salvatore
• 5,980 points
• 5,466 views
0 votes
1 answer

Encrypting few variables and embedding them in playbook

Hey @Camron, you can just encrypt those ...READ MORE

Mar 7, 2019 in Ansible by Fez
• 2,481 views
0 votes
1 answer

How do i automatically install galaxy roles?

You should use a requirements.yml file for this use-case. ...READ MORE

Mar 12, 2019 in Ansible by William
• 2,251 views
0 votes
1 answer

How do I deploy Rancher on a Linux system?

Step 1: Prepare a Linux host and install ...READ MORE

Mar 28, 2019 in Kubernetes by Shlok
• 1,552 views
0 votes
1 answer

Prerequisites for learning puppet

You should have an understanding of the ...READ MORE

Mar 8, 2019 in Puppet by Amish
• 2,412 views
0 votes
1 answer

New release Kubernetes 1.14 - 25 March 2019 - Features

A new Kubernetes release was made on ...READ MORE

Mar 29, 2019 in Kubernetes by Kalgi
• 1,492 views
0 votes
1 answer

How does Puppet apply configuration to agent nodes?

Puppet follows this workflow: There is a factor ...READ MORE

Mar 8, 2019 in Puppet by Veena
• 2,399 views
0 votes
1 answer

How does Puppet master and node communicate?

Puppet master communicates with puppet agent via ...READ MORE

Mar 11, 2019 in Puppet by Kim
• 2,255 views
0 votes
1 answer

How do I use my static and dynamic inventory files together in an ansible playbook?

Add both your static and dynamic inventories ...READ MORE

Feb 9, 2019 in Ansible by Monish
• 3,550 views
0 votes
1 answer

Error saying "unrecognized service:when trying to start jenkins" while starting jenkins

You are running the wrong command, the ...READ MORE

Dec 19, 2018 in Jenkins by Alan
• 5,785 views
0 votes
1 answer

Error saying "Stack level too deep" while installing puppet.

Hey @Dipti, gem seemed to have not ...READ MORE

Feb 25, 2019 in Puppet by Nandita
• 2,833 views
0 votes
1 answer

Make Ansible throw an error inside the role

Hey @Nisha, you can use the block/rescue ...READ MORE

Mar 13, 2019 in Ansible by Kim
• 2,110 views
0 votes
1 answer

No pods created after launching a DaemonSet

Kubelet service restart won't help you with ...READ MORE

Dec 28, 2018 in Kubernetes by ajs3033
• 7,300 points
• 5,350 views
0 votes
1 answer

Is there a way to recover lost Ansible Vault password?

Hey @Sridhar, There is no way to ...READ MORE

Jan 29, 2019 in Ansible by Akthia
• 3,951 views
0 votes
1 answer

CRC check failed error when pulling ansible role from git

You can try adding --no-wait option to the ansible-galaxy import call ...READ MORE

Mar 14, 2019 in Ansible by Kanika
• 2,059 views
0 votes
1 answer

Playbook to add ec2 instance to ELB

Hey, @Kishore, try something like this: - hosts: ...READ MORE

Mar 26, 2019 in Ansible by Yesha
• 1,562 views
0 votes
1 answer

Monitor SMTP services on a host system using Nagios

The check_smtp plugin can be used for monitoring your ...READ MORE

Mar 1, 2019 in Nagios by Kavya
• 2,590 views
0 votes
1 answer

Vagrant file to bring up VM using Puppet

You vagrant file should look something like ...READ MORE

Mar 12, 2019 in Puppet by Barbara
• 2,114 views
+1 vote
1 answer

Error saying "Package not a legal parameter in an Ansible task or a handler" - Ansible

This has been happening to a lot ...READ MORE

Jan 8, 2019 in Ansible by Takeshi
• 4,773 views
0 votes
1 answer

confirm r10k installation and configuration

Hey @Nisha, to confirm the installation and ...READ MORE

Mar 8, 2019 in Puppet by Barbara
• 2,270 views
0 votes
2 answers

where to set the context path - jenkins

Put this into /etc/apache2/other/jenkins.conf: ProxyPass ...READ MORE

Aug 10, 2018 in Jenkins by Nilesh
• 7,060 points
• 11,318 views
0 votes
1 answer

Playbook to create availability disk for a VM

Hey @Chandan, try something like this: - name: ...READ MORE

Mar 27, 2019 in Ansible by Harsh
• 1,467 views
0 votes
1 answer

View the encrypted file without decrypting - Ansible Vault

Hey @Laksha, you can view the file ...READ MORE

Mar 6, 2019 in Ansible by William
• 2,327 views
0 votes
1 answer

Nginx routing for kubernetes services

Hey, backend is a service running on ...READ MORE

Feb 8, 2019 in Kubernetes by Kalgi
• 52,340 points
• 3,469 views
0 votes
1 answer

Disable SSL redirect for Kubernetes NGINX ingress

Adding ingress.kubernetes.io/ssl-redirect: "false" to annotations will disable the SSL redirect: apiVersion: extensions/v1beta1 kind: ...READ MORE

Sep 12, 2018 in Kubernetes by Kalgi
• 52,340 points
• 9,886 views
0 votes
1 answer

How do I install Ansible on windows?

Hi Neha, you cannot have an entire ...READ MORE

Feb 28, 2019 in Ansible by Kavya
• 2,612 views
0 votes
2 answers

Encrypt a single variable using ansible Vault

Adding to @Zunaid's answer, this can also ...READ MORE

Jan 29, 2019 in Ansible by Sid
• 3,834 views
0 votes
1 answer

How do I set up a minikube cluster on Ubuntu?

Minikube is a tool that makes Kubernetes ...READ MORE

Feb 22, 2019 in Kubernetes by Sumit
• 2,819 views
0 votes
1 answer

How do I install Jenkins on ubuntu?

Hey @Chandu, follow these steps to install ...READ MORE

Feb 26, 2019 in Jenkins by Kalgi
• 2,674 views
0 votes
2 answers

Unable to use jenkins to run oracle script on remote DB

add ORACLE_HOME  in jenkins global variable. READ MORE

Mar 27, 2019 in DevOps & Agile by hal
• 8,438 views
0 votes
4 answers

Is it possible to integrate sonarqube with LDAP

Add the following lines in your config ...READ MORE

Apr 29, 2019 in DevOps & Agile by Wazir
• 7,819 views
0 votes
1 answer

Install LAMP Stack by creating a new module - Puppet

Hey @Ruth, yes you can set up ...READ MORE

Mar 11, 2019 in Puppet by Shalaka
• 2,067 views
0 votes
1 answer

What is vault id?

A vault id is an identifier for ...READ MORE

Mar 7, 2019 in Ansible by William
• 2,266 views
0 votes
1 answer

Manage large number of roles

I had close to 200 roles. All of ...READ MORE

Mar 13, 2019 in Ansible by Levin
• 1,970 views
0 votes
1 answer

Ingress nginx loading resource 404 in kubernetes

This is not a routing problem on ...READ MORE

Sep 10, 2018 in Kubernetes by Kalgi
• 52,340 points
• 9,912 views
0 votes
1 answer

Ansible playbook with jenkins not working

When you execute the playbook under Jenkins, ...READ MORE

Jan 17, 2019 in Ansible by Sameer
• 4,318 views
0 votes
1 answer

External IP not working with Minikube Kubernetes

You can use an ingress controller on ...READ MORE

Jan 24, 2019 in Kubernetes by DareDev
• 6,890 points
• 4,005 views
+1 vote
1 answer

issue while deploying a war file through jenkins in docker container

Please make sure while deploying to the ...READ MORE

Dec 17, 2018 in Jenkins by Arohi
• 5,577 views
0 votes
1 answer

Error while installing ansible-galaxy on Mac

Run the following to upgrade setuptools under ...READ MORE

Mar 13, 2019 in Ansible by Haider
• 1,910 views
0 votes
1 answer

How does Puppet use Resource Abstraction Layer(RAL)?

Resource Abstraction Layer uses puppet resources and ...READ MORE

Mar 8, 2019 in Puppet by Veena
• 2,114 views
0 votes
1 answer

git error: RPC failed; curl 56 GnuTLS recv error

This is simple, you’re probably missing openssl ...READ MORE

Sep 26, 2018 in Git & GitHub by Tyrion anex
• 8,690 points
• 9,125 views
0 votes
1 answer

How to install Saltstack on CentOS?

Hey @Dipti, follow these steps to install ...READ MORE

Feb 27, 2019 in DevOps Tools by Avinash
• 2,459 views
0 votes
1 answer

How do I get an ENV variable and store it into a local variable - Ansible

Hey @Ninja, that is possible. What you ...READ MORE

Jan 24, 2019 in Ansible by Thomas
• 3,910 views
0 votes
2 answers

Node unable to join cluster - saying token expired

@Eric's answer is on point. There's another ...READ MORE

Jan 16, 2019 in Kubernetes by Keshav
• 4,199 views
0 votes
1 answer

How does idempotency make puppet special?

idempotency helps in managing a particular machine ...READ MORE

Mar 8, 2019 in Puppet by Veena
• 2,029 views
0 votes
2 answers

Error saying "File[/etc/httpd/conf/mods-enabled/proxy.conf] is already defined; cannot redefined"

This error occurs when you try to ...READ MORE

Mar 5, 2019 in Puppet by Kyraa
• 2,119 views
0 votes
1 answer

How do I install maven on ubuntu?

Hey @Kiran, Installing Maven on Ubuntu is ...READ MORE

Feb 19, 2019 in Other DevOps Questions by Jobin
• 2,745 views
0 votes
1 answer

How do I install Splunk on Windows?

Hi haseeb, you can install Splunk Enterprise ...READ MORE

Feb 28, 2019 in DevOps Tools by Kalgi
• 2,347 views
0 votes
1 answer

Organize roles - Ansible roles

One of the ways is to use ...READ MORE

Mar 13, 2019 in Ansible by Haider
• 1,788 views