Trending questions in DevOps & Agile

0 votes
2 answers

NoSuchBucket error when running Kubernetes on AWS

It was a bug on their part. ...READ MORE

Sep 4, 2018 in Kubernetes by Nilesh
• 7,060 points
• 2,621 views
0 votes
1 answer

Call endpoint periodically from kubernetes cron jon

Cron job would be appropriate to use. ...READ MORE

Sep 17, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,100 views
+5 votes
2 answers

Redirecting host to service path in kubernetes

What you are trying to do is ...READ MORE

Mar 27, 2018 in Kubernetes by DragonLord999
• 8,450 points
• 5,055 views
0 votes
1 answer

Persisting data in a docker swarm with glusterfs

You will have to create a volume ...READ MORE

Aug 24, 2018 in Docker by Nilesh
• 7,060 points
• 3,108 views
0 votes
2 answers

Running Kubernetes in multimaster mode

I had the same issue and using ...READ MORE

Sep 6, 2018 in Kubernetes by Nilesh
• 7,060 points
• 2,504 views
0 votes
1 answer

Docker for windows error: Database lost on docker restart

If you are using docker-compose down/up, keep in ...READ MORE

Sep 20, 2018 in DevOps & Agile by Tyrion anex
• 8,690 points
• 1,948 views
0 votes
1 answer

oci runtime error while running kubernetes on rancher cluster

You need to switch Docker to 1.12.x; ...READ MORE

Sep 6, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,513 views
+1 vote
1 answer

Run a cron job once in N hours

If you want your cron job to ...READ MORE

Sep 18, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,934 views
0 votes
1 answer

Permission denied when running ansible playbook through jenkins

Jenkins uses it's own user to execute ...READ MORE

Jun 25, 2018 in Ansible by DareDev
• 6,890 points
• 5,626 views
0 votes
1 answer

Is it possible to access GCP resources using api without a user interaction.?

yes that's totally possible. You'd have to create ...READ MORE

Sep 19, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,907 views
0 votes
1 answer

Networking between two pods

Define service resources for both your front-end ...READ MORE

Sep 24, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,685 views
0 votes
1 answer

Build error in TF build definition

I think the problem is in your ...READ MORE

Aug 3, 2018 in DevOps Tools by ajs3033
• 7,300 points
• 3,929 views
+1 vote
1 answer

Error while running docker run command

This error occurs when your port is ...READ MORE

Jul 26, 2018 in Docker by Kalgi
• 52,340 points
• 4,227 views
0 votes
1 answer

Filter source ip in kubernetes ingress in GCE

This feature currently works only with nginx. Example ...READ MORE

Sep 7, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,403 views
0 votes
1 answer

Is possible to have same k8s service for multiple pods?

Reserve a static IP and then assign ...READ MORE

Jul 20, 2018 in Kubernetes by Kalgi
• 52,340 points
• 4,518 views
0 votes
1 answer

How to a run deployed app in Docker for Windows?

To deploy an ASP.NET web application to ...READ MORE

Aug 30, 2018 in DevOps & Agile by Tyrion anex
• 8,690 points
• 2,772 views
+3 votes
4 answers

Chef vs puppet

Both chef and puppet have their own ...READ MORE

Aug 14, 2018 in Chef by Sahil
• 3,270 views
0 votes
1 answer

Docker mulitstage build jenkins

Make a few changes in your dockerfile Basically ...READ MORE

Aug 8, 2018 in Jenkins by Kalgi
• 52,340 points
• 3,679 views
0 votes
1 answer

Traefik with Docker Stack doesn't detect port

When using traefik configured for swarm mode, ...READ MORE

Aug 29, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,763 views
0 votes
1 answer

gerrit-cherry-pick:fatal: 'origin' does not appear to be a git repository

The user account making that command does ...READ MORE

Aug 13, 2018 in Git & GitHub by Kalgi
• 52,340 points
• 3,449 views
0 votes
1 answer

Managers information from workers - Docker swarm

As of now there's no way to ...READ MORE

Oct 8, 2018 in Docker by Kalgi
• 52,340 points
• 1,993 views
0 votes
1 answer

How do I copy files from host to Docker container?

Here is what you can use to ...READ MORE

Aug 28, 2018 in DevOps & Agile by Damon Salvatore
• 5,980 points
• 2,819 views
0 votes
1 answer

Kubernetes Cronjob Only Runs Half the Time

The external circumstances prevents them from running ...READ MORE

Sep 18, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,881 views
0 votes
1 answer

How to run a docker command from inside the container?

You must have come across the /var/run/docker.sock file, ...READ MORE

Jun 28, 2018 in Docker by Sophie may
• 10,620 points
• 5,420 views
0 votes
1 answer

Unable to access pods using nodeIP

Your kubernetes cluster is missing the ingress ...READ MORE

Sep 7, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,348 views
0 votes
1 answer

ConfigMaps volume not creating file in container

Did a little research and found the ...READ MORE

Sep 6, 2018 in Kubernetes by Atul
• 10,240 points
• 2,382 views
0 votes
1 answer

502 Error pages when trying to run ingress

In order for Ingress to work on ...READ MORE

Sep 12, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,129 views
+1 vote
2 answers

What possible return values are there in Jenkins plugin “Sonarqube scanner”

Use Webhooks in SonarQube Administration setup to ...READ MORE

Aug 3, 2018 in Jenkins by Nilesh
• 7,060 points
• 6,501 views
0 votes
1 answer

Jenkins Docker Pipelining inside Docker

The issue is here: /var/jenkins_home/workspace/alfred-master@tmp/durable-713ce0d7/script.sh: 2: /var/jenkins_home/workspace/alfred-master@tmp/durable-713ce0d7/script.sh: docker: ...READ MORE

Aug 1, 2018 in Docker by Kalgi
• 52,340 points
• 3,905 views
0 votes
1 answer

Push from phpstorm to bitbucket

I think you haven’t committed the changes ...READ MORE

Aug 14, 2018 in Git & GitHub by Kalgi
• 52,340 points
• 3,344 views
0 votes
1 answer

Unable to switch filesystem to overlay in Docker in Ubuntu.

From the official docs: https://docs.docker.com/engine/userguide/storagedriver/overlayfs-driver/#configure-docker-with-the-overlayoverlay2-storage-driver To configure Docker ...READ MORE

Jul 18, 2018 in Docker by ajs3033
• 7,300 points
• 4,508 views
0 votes
1 answer

Study resources for learning Docker

This a playlist of everything about docker, ...READ MORE

Sep 24, 2018 in Docker by Hannah
• 18,520 points
• 1,569 views
+1 vote
2 answers

error saying, “cannot create, files already exist” while installing virtual machine on Virtual Box

Hey @Hannah, You'll have to reinitialize the ...READ MORE

Oct 25, 2018 in DevOps Tools by krishti
• 2,622 views
0 votes
1 answer

Unable to run Kubernetes on rancher cluster

switch Docker to 1.12.x; Kubernetes doesn't support ...READ MORE

Aug 28, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,705 views
+1 vote
1 answer

Resources to learn Jenkins

To start of with basics you can ...READ MORE

Sep 21, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,621 views
+1 vote
1 answer

How to kill a specific instance on Pivotal Cloud Foundry

Use the following command cf restart-app-instance This will issue ...READ MORE

Jul 25, 2018 in Other DevOps Questions by Kalgi
• 52,340 points
• 4,111 views
0 votes
1 answer

Error: Cannot access server in docker container

Try to publish your port: docker run -p ...READ MORE

Sep 7, 2018 in Docker by Tyrion anex
• 8,690 points
• 2,278 views
0 votes
1 answer

What is unknown user client in kubernetes?

I think your Legacy Authorisation has been ...READ MORE

Sep 12, 2018 in Kubernetes by DareDev
• 6,890 points
• 2,004 views
0 votes
1 answer

docker set iptables options in docker-compose.yml

The --iptables option only applies to the ...READ MORE

Aug 2, 2018 in Docker by Kalgi
• 52,340 points
• 3,775 views
0 votes
1 answer

Dokku Multiple app in single repo

You can use the dokku-monorepo plugin. It’s ...READ MORE

Jul 16, 2018 in Other DevOps Questions by Kalgi
• 2,680 points
• 4,492 views
0 votes
1 answer

Cannot download Docker images behind a proxy

Follow these steps Step 1- create a systemd ...READ MORE

Jul 27, 2018 in Docker by Kalgi
• 52,340 points
• 4,011 views
0 votes
1 answer

Change apiserver runtime service

The apiserver is declared by a static ...READ MORE

Sep 19, 2018 in Kubernetes by Kalgi
• 52,340 points
• 1,674 views
0 votes
1 answer

How to connect to Vault server

You need to configure the back end ...READ MORE

Jul 12, 2018 in DevOps Tools by Kalgi
• 2,680 points
• 4,655 views
0 votes
1 answer

ingress port getting redirected in kubernetes

Try the following, it worked for me Changed ...READ MORE

Sep 10, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,059 views
0 votes
1 answer

Docker Swarm- Build image only when stack deployed from manager node

Use docker build to build the image. ...READ MORE

Aug 24, 2018 in Docker by Nilesh
• 7,060 points
• 2,785 views
0 votes
1 answer

Not able to access kubernetes api from a pod in azure

Follow these steps Add --bind-address=0.0.0.0 option to the line https://github.com/kubernetes/kubernetes/blob/v1.2.0/docs/getting-started-guides/coreos/azure/cloud_config_templates/kubernetes-cluster-main-nodes-template.yml#L218  Created ...READ MORE

Aug 30, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,525 views
+2 votes
5 answers

main roles of DevOps

Can you please brief about the roles ...READ MORE

Oct 16, 2018 in DevOps & Agile by Haider
• 4,585 views
0 votes
1 answer

Traefik as kubernetes ingress

Try something like this apiVersion: v1 kind: Service metadata: ...READ MORE

Sep 11, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,002 views
0 votes
2 answers

Monitoring kubernetes job

you can do watch 'kubectl get pods | ...READ MORE

Sep 3, 2018 in Kubernetes by Nilesh
• 7,060 points
• 2,298 views
0 votes
2 answers

Adding nameservers to kubernetes

For those usign Kubernetes kube-dns, flag -nameservers nor environment variable SKYDNS_NAMESERVERS are ...READ MORE

Sep 3, 2018 in Kubernetes by Kalgi
• 52,340 points
• 2,294 views