Error saying must specify a listening address

0 votes

ScaleWay gives my server an IP address that is not attached to a local interface as it gives the following error

# docker swarm init --advertise-addr <my-external-ip>:2377 --listen-addr 0.0.0.0:2377
Error response from daemon: must specify a listening address
because the address to advertise is not recognized as a system address

How is docker swarm supposed to be setup in such an environment?

Aug 24, 2018 in Docker by lina
• 8,220 points
• 2,696 views

1 answer to this question.

0 votes

To define non system IP Address: IP Addresses used with technologies like DNAT. These IP Addresses are not set on local interface and visible to underlying operating system.

answered Aug 24, 2018 by Nilesh
• 7,060 points

Related Questions In Docker

+6 votes
4 answers

Error: Docker saying "bad file descriptor"

The solution was easy enough. Add these ...READ MORE

answered Mar 27, 2018 in Docker by DragonLord999
• 8,450 points
• 11,656 views
0 votes
1 answer

Error saying "context cancelled"

This error occurs when your port is ...READ MORE

answered Jul 26, 2018 in Docker by Kalgi
• 52,340 points
• 6,366 views
+2 votes
1 answer
+5 votes
7 answers

Docker swarm vs kubernetes

Swarm is easy handling while kn8 is ...READ MORE

answered Aug 27, 2018 in Docker by Mahesh Ajmeria
• 9,659 views
0 votes
1 answer

Error saying "build" requires 1 argument. See 'docker build --help'

Try adding a period at the end ...READ MORE

answered Jul 18, 2018 in Docker by Nilesh
• 7,060 points
• 6,410 views
0 votes
1 answer

Init could not choose ip address error while doing docker swarm init

First look for the public IP of ...READ MORE

answered Aug 23, 2018 in Docker by Nilesh
• 7,060 points
• 5,256 views
webinar REGISTER FOR FREE WEBINAR X
REGISTER NOW
webinar_success Thank you for registering Join Edureka Meetup community for 100+ Free Webinars each month JOIN MEETUP GROUP